Get in touch
Back
Downtime

Europe Node 2 SMTP, Europe Node 2 IMAP, Europe Node 2 POP3, and 1 other service are down

Started 21 Jun at 09:49am CEST, resolved 21 Jun at 09:54am CEST.

Europe Node 2 SMTP Europe Node 2 IMAP Europe Node 2 POP3
Resolved

Europe Node 2 SMTP, Europe Node 2 IMAP, and Europe Node 2 POP3 recovered.

Posted 21 Jun at 09:54am CEST.
Created

Europe Node 2 SMTP, Europe Node 2 IMAP, and Europe Node 2 POP3 went down.

Posted 21 Jun at 09:49am CEST.